|
Synology 213 unable to load UTF-8 after DSM 5 upgrade
|
|
17-08-2014, 19:09
Post: #1
|
|||
|
|||
|
Synology 213 unable to load UTF-8 after DSM 5 upgrade
Had been running minim server 0.72 smoothly with DSM 4.3 on my Synology 213. Owing to the recent Synolocker threat I upgraded my NAS to DSM 5.0-4493 update 3 with minim server 0.82. Don't know why minim now can only start with ASCII charset ("Platform default charset is US-ASCII") instead of UTF-8 and as a result my non-English songs are all disappeared. Tried both Java SE Embedded 7 and 8 but it didn't help. Also tried reinstalling minim 0.72 and received the "UTF-8 locale and charset not available" message. Anyone encountered the same issue ? Is this a compatibility issue between minim 0.82 and DSM 5 ? Thanks in advance for all your suggestions and answers !
|
|||
|
17-08-2014, 20:49
Post: #2
|
|||
|
|||
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
(17-08-2014 19:09)JohnTan Wrote: Had been running minim server 0.72 smoothly with DSM 4.3 on my Synology 213. Owing to the recent Synolocker threat I upgraded my NAS to DSM 5.0-4493 update 3 with minim server 0.82. Don't know why minim now can only start with ASCII charset ("Platform default charset is US-ASCII") instead of UTF-8 and as a result my non-English songs are all disappeared. Tried both Java SE Embedded 7 and 8 but it didn't help. Also tried reinstalling minim 0.72 and received the "UTF-8 locale and charset not available" message. Anyone encountered the same issue ? Is this a compatibility issue between minim 0.82 and DSM 5 ? Thanks in advance for all your suggestions and answers ! There isn't a compatibility issue between MinimServer 0.8.2 and DSM 5.0. I am running both of these with no problems. If you login to the NAS with SSH and type the command: locale -a what output do you get? |
|||
|
18-08-2014, 12:24
Post: #3
|
|||
|
|||
|
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
Hi Simon ! Thanks for your prompt response and here is the output :
DiskStation> locale -a locale: Cannot set LC_CTYPE to default locale: No such file or directory C cs_CZ.utf8 da_DK.utf8 de_DE.utf8 en_US.utf8 es_ES.utf8 fr_FR.utf8 hu_HU.utf8 it_IT.utf8 ja_JP.utf8 ko_KR.utf8 nb_NO.utf8 nl_NL.utf8 pl_PL.utf8 POSIX pt_BR.utf8 pt_PT.utf8 ru_RU.utf8 sv_SE.utf8 tr_TR.utf8 zh_CN.utf8 zh_TW.utf8 DiskStation> |
|||
|
18-08-2014, 15:03
(This post was last modified: 18-08-2014 15:03 by simoncn.)
Post: #4
|
|||
|
|||
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
(18-08-2014 12:24)JohnTan Wrote: Hi Simon ! Thanks for your prompt response and here is the output : This shows the correct utf8 locales are installed on your NAS. The error message: locale: Cannot set LC_CTYPE to default locale: No such file or directory looks like the cause of the problem. It seems that something went wrong with your locale configuration when you updated from DSM 4.3 to DSM 5.0. I get the following output on DSM 5.0: DS713> locale -a C POSIX cs_CZ.utf8 da_DK.utf8 de_DE.utf8 en_US.utf8 es_ES.utf8 fr_FR.utf8 hu_HU.utf8 it_IT.utf8 ja_JP.utf8 ko_KR.utf8 nb_NO.utf8 nl_NL.utf8 pl_PL.utf8 pt_BR.utf8 pt_PT.utf8 ru_RU.utf8 sv_SE.utf8 tr_TR.utf8 zh_CN.utf8 zh_TW.utf8 I've never seen this "Cannot set LC_CTYPE" message and I don't know how to fix it. I think your safest option is contact Synology support for advice. |
|||
|
22-08-2014, 12:13
Post: #5
|
|||
|
|||
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
(18-08-2014 15:03)simoncn Wrote:(18-08-2014 12:24)JohnTan Wrote: Hi Simon ! Thanks for your prompt response and here is the output : I have the same problem as JohnTan. Does JohnTan (or anyone) solve the problem ? For Simon : when I use synology media server (and not minimserver) with Kinsky or Lumin app on my IPAD I have no problem with UTF-8 (french songs and folders are ok). Ma question : the problem is MinimServer or DSM 5.0 configuration ? Thanks for all |
|||
|
22-08-2014, 12:33
Post: #6
|
|||
|
|||
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
(22-08-2014 12:13)gerard Wrote: I have the same problem as JohnTan. The problem is caused by DSM 5.0. I have informed Synology about this. MinimServer uses Java, which requires a correct DSM locale setting to be able to read files and folders containing non-English characters. Synology Media Server doesn't use Java, so it can read these files and folders even though the DSM locale setting is incorrect. |
|||
|
23-08-2014, 07:38
Post: #7
|
|||
|
|||
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
(22-08-2014 12:33)simoncn Wrote:(22-08-2014 12:13)gerard Wrote: I have the same problem as JohnTan. Thanks Simon ! Now I don't have to try re-building the whole NAS. Does that mean I now have to wait for their next DSM update assuming it will be fixed ? |
|||
|
23-08-2014, 10:37
Post: #8
|
|||
|
|||
| RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade | |||
|
23-08-2014, 14:59
(This post was last modified: 23-08-2014 15:01 by tarnkappe.)
Post: #9
|
|||
|
|||
|
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
Did you uninstall and reinstall java? AFAIR the description of the java installer package that I am using tells you have to reinstall java after a system upgrade to make the locales work correct.
On my synology DS213 minimserver shows the utf8 tags fine. Even the peace sign of prince's sign O the times album is displayed in the naim N-Stream app. |
|||
|
24-08-2014, 12:08
Post: #10
|
|||
|
|||
|
RE: Synology 213 unable to load UTF-8 after DSM 5 upgrade
This turned out to be a DSM upgrade issue and thanks tarnkappe for telling me that his DS213 is running well with DSM 5. I ended up re-setting my DS213 with complete DSM 5.0 firmware re-installed and the problem is now resolved. Thanks everyone for your assistance and suggestions !
|
|||
|
« Next Oldest | Next Newest »
|
User(s) browsing this thread: 1 Guest(s)

Search
Member List
Calendar
Help



